欢迎来到亿航财经网,一家专业股票配资、期货开户、外汇交易知识分享的正规金融网站!
当前位置:财经网 > 期货交易 > 正文

「宏源期货」波段启动选股公式怎么操作?

出处:亿航财经网 时间:2020-07-09 08:35:01 作者:宏源期货 阅读: 字数:4158字

简介:本文标题:「宏源期货」波段启动选股公式怎么操作?
   本文链接:http://www.ipschool.net/qhjy/110968.html
   内容由宏源期货整理编辑,一共4158个字,关键词是公式波段选股;主要讲解的内容是如果大家看过小编之前写过的文章,应该能够了解波段选股的重要性,但是波段选股是有一定的公式的, 波段启动选股公式 要怎么操作呢?大家可以参考以下的波段选股代码来实现。......的相关信息,具体详情请阅读下文。

  如果大家看过小编之前写过的文章,应该能够了解波段选股的重要性,但是波段选股是有一定的公式的,波段启动选股公式要怎么操作呢?大家可以参考以下的波段选股代码来实现。

  {公式名称: 波段副图}

  {公式类型: 技术指标公式-其他类型

  画线方法: 副图}

  AP1:=CROSS(MA(CLOSE,5),MA(CLOSE,24));

  AP2:=CROSS(MA(VOL,5),MA(VOL,60)) OR CROSS(VOL,MA(VOL,60));

  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIFF,9);

  AP3:=DIFF>DEA;

  AP4:=EVERY(REF(CLOSE,1)/REF(CLOSE,2)<1.03,6) AND HIGH/MAX(CLOSE,OPEN)<1.01 AND EVERY(REF(MAX(CLOSE,OPEN),1)/REF(MIN(CLOSE,OPEN),1)<1.02,5);

  AP5:=OPEN/REF(MAX(CLOSE,OPEN),1)<1.01;

  AP6:=EVERY(REF(HIGH,1)/REF(MAX(CLOSE,OPEN),2)<1.02,3) AND MAX(CLOSE,OPEN)/LOW<1.02;

  AP7:=LOWMA(CLOSE,60) AND BETWEEN(MA(CLOSE,24)/MA(CLOSE,60),0.98,1.02) AND CLOSE/REF(CLOSE,1)<1.03;

  AP8:=BETWEEN(MA(CLOSE,24)/MA(CLOSE,60),0.98,1.02);

  XG:AP1 AND AP2 AND AP3 AND AP4 AND AP5 AND AP6 AND (AP7 OR AP8);

  {公式名称: 波段选股}

  {公式类型: 条件选股公式-其他类型}

  AP1:=CROSS(MA(CLOSE,5),MA(CLOSE,24));

  AP2:=CROSS(MA(VOL,5),MA(VOL,60)) OR CROSS(VOL,MA(VOL,60));

  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIFF,9);

  AP3:=DIFF>DEA;

  AP4:=EVERY(REF(CLOSE,1)/REF(CLOSE,2)<1.03,6) AND HIGH/MAX(CLOSE,OPEN)<1.01 AND EVERY(REF(MAX(CLOSE,OPEN),1)/REF(MIN(CLOSE,OPEN),1)<1.02,5);

  AP5:=OPEN/REF(MAX(CLOSE,OPEN),1)<1.01;

  AP6:=EVERY(REF(HIGH,1)/REF(MAX(CLOSE,OPEN),2)<1.02,3) AND MAX(CLOSE,OPEN)/LOW<1.02;

  AP7:=LOWMA(CLOSE,60) AND BETWEEN(MA(CLOSE,24)/MA(CLOSE,60),0.98,1.02) AND CLOSE/REF(CLOSE,1)<1.03;

  AP8:=BETWEEN(MA(CLOSE,24)/MA(CLOSE,60),0.98,1.02);

  XG:AP1 AND AP2 AND AP3 AND AP4 AND AP5 AND AP6 AND (AP7 OR AP8);

  指标没有未来函数,一个月能选出10个左右的股票。选出的股适合做小中线,一般收益都比较稳定的,做短线炒股的朋友还是不要使用。

  指标本来是要发到藏经阁里面的,售价50金币,后来一想都是小散户,还是算了,再加上本人也鄙视那些卖指标的,有本事的都去赚股市的钱了,不会在这里费尽心思卖指标赚钱。

  别的不多说,来看看指标的选股信号

  公式有导入密码,因为这个公式的作者,加了导入密码,并且公式是完全加密,,,,,

  安装方法比较特殊:

  把T0002文件夹中的 PriGS.dat 改改名,把附件里的文件PriGS.dat 解压到T0002,就可以测试公式,记得测试完毕,就恢复原来的 PriGS.dat 文件,就可以恢复原来通达信的自编公式了。

  VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

  VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

  VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

  VAR6:=(VAR3+VAR4+VAR5)/3;

  VAR7:=EMA(VAR6,5);

  指标: EMA(EMA(VAR3,5),5)*3, COLORSTICK;

  VAR8:=IF(VAR6<=-20,10,0);

  VAR9:=HHV(VAR8,10);

  STICKLINE(VAR8=10,20,10,5,0),COLOR6666FF;

  VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

  K:EMA(VAR7,5)*2, , COLORFF00FF;

  D:EMA(K,5), , COLORWHITE;

  J:K*3-D*2, ,COLORYELLOW;

  VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;

  换手:= VOL/CAPITAL*100, , COLORYELLOW;

  成交〖万手〗:=VOL/10000, ,COLORWHITE;

  DRAWTEXT(VAR8=10 AND FILTER(VAR8=10,5),-10{15},'近底部'),LINETHICK1,COLORYELLOW;

  STICKLINE(VAR8=10 AND FILTER(VAR8=10,5),-1.6{20},-10,5,0),COLORYELLOW;

  DRAWTEXT(VARA=20,15,'底部'),LINETHICK1,COLORWHITE;

  STICKLINE((VARA=20),0,10,5,0),COLORWHITE;

  VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG

  (3,5),2)<=REF(ZIG(3,5),3));

  VARD:=(ZIG(3,5)=REF(ZIG(3,5),2)) AND (REF(ZIG

  (3,5),2)>=REF(ZIG(3,5),3));

  STICKLINE((VARC=1),(-14),0,4,0),COLOR0000FF;

  DRAWTEXT((VARC=1),(-14),'买'),COLOR0000FF;

  STICKLINE((VARD=1),14,0,4,0),COLOR00FF00;

  DRAWTEXT((VARD=1),18,'卖'),COLOR00FF00;

  VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

  VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

  ((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

  ((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  VAR11:=VARFREF(VOL,1) AND CLOSE>REF(CLOSE,1);

  DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,15,'大资金活动'),LINETHICK1,COLORFF00FF;

  {STICKLINE(VAR11 AND COUNT(VAR11,30)=1,1,10,5,0),COLORFF00FF;}

  VAR12:=(HIGH+LOW+CLOSE)/3;

  VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

  VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

  VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

  VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

  VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

  VAR18:=100-ABS(VAR17);

  VAR19:=IF(VAR18<90,VAR18,100);

  VAR1A:=IF(VARE>0,VARE,0);

  VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

  VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

  DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,15,'大笔出货'),LINETHICK1,COLORFFCC66;

  STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,0,10,5,0),COLORFFCC66;

  以上就是波段启动选股公式所需要的代码了,大家想要尝试波段选股的可以来实际操作一把了,应该比较容易成功,如果还有想要了解的内容,可以持续关注下亿航财经网更新的文章。

  以就是有关“「宏源期货」波段启动选股公式怎么操作?”的相关信息了,文章阅读到这里的小伙伴们应该都清楚了小编所讲的含义了吧,更多精彩内容可持续关注亿航财经网!

  
  • 相关推荐:
  •   
    关键词:公式波段选股

    上一篇:「安徽水利股吧」乌龙指跌停到涨停是怎样的?

    下一篇:「现代牧业股票价格」跳空高开涨停后市如何?

    声明文章旨在促进信息交流,不以盈利为目的,本文观点与本站立场无关,不承担任何责任。部分内容文章及图片来自互联网或自媒体,版权归属于原作者,不保证该信息(包括但不限于文字、图片、图表及数据)的准确性、真实性、完整性、有效性、及时性、原创性等,如无意侵犯媒体或个人知识产权,请来电或致函告之,本站将在第一时间处理。未经证实的信息仅供参考,不做任何投资和交易根据,据此操作风险自担。本站拥有对此声明的最终解释权。

    如需转载文章请保留链接:http://www.ipschool.net/qhjy/110968.html

    19105008565

    联系热线

    手机在线

    手机扫一扫,随时随地在线关注最新财经行情动态,了解更多一手金融资讯。
    新浪微博添加关注
    在线咨询 分析顾问微信客服
    扫一扫添加微信
    广告合作Top
    长按图片 添加客服微信号